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Chapter 1 Telegram introduction

PROFINET, launched by PROFIBUS International, is a new generation automation bus standard based on

industrial Ethernet technology. It can meet various communication requirements in industrial automation scenarios,

and is an industrial network protocol that supports high performance, high reliability and high real-time

performance.

PROFINET provides three types of channels: standard channel, real-time channel (RT), isochronous real-time

channel (IRT), standard channel is a non-real-time protocol based on TCP/IP protocol, and RT and IRT channel is

implemented based on Ethernet.

1.1 Supported telegram

Kinco PN servo drives (PN firmware version 00000005 or 10000005) support telegram 1, 3, 5, 9, 102, 105,

and 111, covering AC (Application Class) 1, 3, and 4, as shown in Table 1-1. Additional telegram 750 is not

currently supported.

Table 1-1 Available telegram

Application Class telegram number

AC1 1

AC3 9,111

AC4 3,5,102,105

Note

 PN firmware 00000004 only supports telegram 1, 111, and 3(IRT is not supported). The PN
firmware version can be found in [308001], see Table 2-1 for details.

The structure of each packet are as follows:

Table 1-2 telegram 1 (Application Class 1)

I/O data number
telegram 1

Set value Actual value

1 STW1 ZSW1

2 NSOLL_A NIST_A
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Table 1-3 telegram 9, 111 (Application Class 3)

I/O data number
telegram 9 telegram 111

Set value Actual value Set value Actual value
1 STW1 ZSW1 STW1 ZSW1
2 SATZANW AKTSATZ POS_STW1 POS_ZSW1
3 STW2 ZSW2 POS_STW2 POS_ZSW2
4

MDI_TARPOS XIST_A
STW2 ZSW2

5 OVERRIDE MELDW
6

MDI_VELOCITY MDI_TARPOS XIST_A
7
8 MDI_ACC

MDI_VELOCITY NIST_B
9 MDI_DEC
10 MDI_MOD MDI_ACC FAULT_CODE
11 MDI_DEC WARN_CODE
12 User User

Table 1-4 telegram 3, 5, 102 ,105 (Application Class 4)

I/O data
number

telegram 3 telegram 102 telegram 5 telegram 105
Set value Actual value Set value Actual value Set value Actual value Set value Actual value

1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1
2

NSOLL_B NIST_B NSOLL_B NIST_B NSOLL_B NIST_B NSOLL_B NIST_B
3
4 STW2 ZSW2 STW2 ZSW2 STW2 ZSW2 STW2 ZSW2
5 G1_STW G1_ZSW MOMRED MELDW G1_STW G1_ZSW MOMRED MELDW
6

G1_XIST1
G1_STW G1_ZSW

XERR G1_XIST1
G1_STW G1_ZSW

7
G1_XIST1 XERR G1_XIST1

8
G1_XIST2 KPC G1_XIST2

9
G1_XIST2 KPC G1_XIST2

10

1.2 I/O data signal

I/O data signal (set value and actual value) are used to compose the telegram, and the following table provides all

signals for the I/O data.

Table 1-5 Signal table

Singal Abbreviation Data type Description
Control word 1 STW1 U16 See Section 1.3.1
Status word 1 ZSW1 U16
Control word 2 STW2 U16 See Section 1.3.2
Status word 2 ZSW2 U16

Speed setpoint A NSOLL_A I16 4000h corresponds to the reference speed a

Speed actual value A NIST_A I16
Speed setpoint B NSOLL_B I32 40000000h corresponds to the reference speed

Speed actual value B NIST_B b I32
Sensor 1 control word G1_STW U16

See Section 1.3.5Sensor 1 status word G1_ZSW U16
telegram status word MELDW U16
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Singal Abbreviation Data type Description

Sensor 1 position acutal value 1 G1_XIST1 I32
Equal to actual position [606300] plus position shift

[60FB07]. Unit DEC
Sensor 1 position acutal value 2 G1_XIST2 I32 —

Position deviation value XERR I32 —
Position control factor KPC I32 —
Position acutal value A XIST_A I32 Equal to actual position [606300]. Unit DEC

Position table control word SATZANW U16
See Section 1.3.3Position table status word AKTSATZ U16

MDI mode control word MDI_MOD U16
Position control word 1 POS_STW1 U16

See Section 1.3.4
Position status word 1 POS_ZSW1 U16
Position control word 2 POS_STW2 U16
Position status word 2 POS_ZSW2 U16
MDI target position MDI_TARPOS I32 Equal to target position [607A00]. Unit DEC

MDI velocity MDI_VELOCITY U32
Unit DEC, DEC = (RPM * feedback_resolution
[641003] * 512 ) / 1875

MDI acceleration percentage MDI_ACC U16 0~4000h corresponds to 0~100%, 2000h means the
acceleration/deceleration is reduced to 1/2 of the drive
setpointMDI deceleration percentage MDI_DEC U16

MDI velocity percentage OVERRIDE U16
0~4000h corresponds to 0~100%, maximum 199%,
2000h means to reduce the speed to 1/2 of the drive
setpoint

Torque limit value MOMRED I16
0~4000h corresponds to 100%~0, 4000h means the
target current (torque) is limited to 0

Fault code FAULT_CODE U16 —
Warn code WARN_CODE U16 —

Telegram 111 custom receive word User I16
See Section 5.4.1, Article 7

Telegram 111 custom send word User I16
a Reference speed = 1/2 of the maximum speed [607F00].
b When using telegram 111, the speed actual value NIST_B is equal to the actual speed [606C00] in DEC.

1.3 Control word and status word

1.3.1 STW1 and ZSW1

 Control word 1 (STW1)

Table 1-6 STW1 each bit value meaning

Bit
Meaning

telegram 1,3,5,102,105 (Application Class 1, 4) telegram 9,111 (Application Class 3)

0 On / Off (ramp stop a)

1 No coast stop / Coast stop
2 No quick stop / Quick stop
3 Operation enable / Operation disable
4 Enable RFG b / Disable RFG (RFG output is 0) Do not reject traversing task / Reject traversing task
5 Unfreeze RFG / Freeze RFG (RFG input is not updated) No intermediate stop / Intermediate stop
6 Enable setpoint / Disable setpoint (RFG input is 0) Activate traversing task (0→1)
7 Fault acknowledge (0→1)
8 Reserved (Application Class 1, 4 do not support jog) Start reverse jog / Stop reverse jog
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9 Reserved Start forward jog / Stop forward jog
10 Control by PLC / No control by PLC
11 Setpoint is reversed / Setpoint is not reversed Start homing procedure / Stop homing procedure

12~15 Reserved
a When bit 4 of STW1 is 1, ramp stop corresponds to halt mode [605D00], and disable operation after stop. When bit 4 of STW1 is 0,
ramp stop corresponds to shutdown stop mode [605B00].
b RFG = Ramp Function Generator (Trapezoidal curve velocity generator). When using Application Class 4, bit 5 does not work, and
either bit 4 or bit 6 is 0, resulting in an RFG output of 0.
Note：the significance for bit value = 1 is left of the slash ; bit value = 0 is right of the slash .

 Status word 1 (ZSW1)

Table 1-7 ZSW1 each bit value meaning

Bit
Meaning

telegram 1,3,5,102,105 (Application Class 1, 4) telegram 9,111 (Application Class 3)
0 Ready to switch on / Not ready to switch on
1 Ready to operate / Not ready to Operate
2 Operation enabled / Operation disabled
3 Fault present / No fault
4 Coast stop not activated / Coast stop activated
5 Quick stop not activated / Quick stop activated
6 Switching on inhibited / Switching on not inhibited
7 Warn present / No warning

8
Speed error within tolerance range /
Speed error out of tolerance range

Following error within tolerance range /
Following error out of tolerance range

9 Control requested / No control requested
10 f or n reached or exceeded / f or n not reached Target position reached / Not at target position
11 Reserved Reference point set / Reference point not yet set
12 Reserved Traversing task acknowledgement (0→1)
13 Reserved Drive stopped / Drive moving
14 Moving forward / Moving reversely Accelerating / Not accelerating
15 Reserved Decelerating / Not decelerating

Note：the significance for bit value = 1 is left of the slash ; bit value = 0 is right of the slash .

1.3.2 STW2 and ZSW2

 Control word 2 (STW2)

For telegram 3, 5, 102, and 105, valid only in IRT mode.

Table 1-8 STW2 each bit value meaning

Bit Meaning

0~11 Reserved

12~15 PLC heartbeat signal
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Note

 If there is a PLC heartbeat signal error or other abnormal communication, the drive will generate
a "CAN bus fault (alarm code 100.0)" alarm. The user can set Abort_Connection_Mode
[600700] to 1: error processing; set to 0: do not process.

 The alarm time threshold is determined by Guard_Time [100C00](in ms) and Life_Time_Factor

[100D00], and the default value is 1000ms * 3 = 3000 ms.

 Status word 2 (ZSW2)

For telegram 3, 5, 102, and 105, valid only in IRT mode.

Table 1-9 ZSW2 each bit value meaning

Bit Meaning

0~11 Reserved

12~15 Drive heartbeat signal

1.3.3 SATZANW、AKTSATZ、MDI_MOD

 Position table control word (SATZANW)

Used for telegram 9.

Table 1-10 SATZANW each bit value meaning

Bit Meaning

0~2
Index of the position task to be started in the position table (value range: 0~7)
Bit 0~2 are valid only in the position table mode

3~14 Reserved

15
Operating mode selection
= 1 MDI mode
= 0 Position table mode

 Position table status word (AKTSATZ)

Used for telegram 9.
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Table 1-11AKTSATZ each bit value meaning

Bit Meaning

0~4
The index of the actual effective positioning task (value range: 0~31)
Bit 0~4 are valid only in the position table mode

5~14 Reserved

15
Operating mode
= 1 MDI mode activated
= 0 Position table mode activated

 MDI mode control word (MDI_MOD)

Used for telegram 9.

Table 1-12 MDI_MOD each bit value meaning

Bit Meaning

0
Select absolute/relative positioning mode
= 1 Absolute positioning mode
= 0 Relative positioning mode

1~15 Reserved

1.3.4 POS_STW1、POS_STW2、POS_ZSW1、POS_ZSW2

 Position control word 1 (POS_STW1)

Used for telegram 111.

Table 1-13 POS_STW1 each bit value meaning

Bit Meaning

0~2
Index of the position task to be started in the position table (value range: 0~7)
Bit 0~2 are valid only in the position table mode

3~7 Reserved

8
Select absolute/relative positioning mode
= 1 Absolute positioning mode
= 0 Relative positioning mode

9~11 Reserved

12
Absolute positioning mode
= 1 Execute the absolute positioning command immediately according to the target position chang
= 0 The absolute positioning command will not be executed immediately according to the target position change.

13~14 Reserved

15
Operating mode selection
= 1 MDI mode
= 0 Position table mode

 Position control word 2 (POS_STW2)

Used for telegram 111.
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Table 1-14 POS_STW2 each bit value meaning

Bit Meaning
0 Reserved
1 = 1 Set the current position as the homing

2 = 1 Activate homing switch signal

3~13 Reserved
14 = 1 Activate software limit switch signal
15 = 1 Activate hardware limit switch signal

 Position status word 1 (POS_ZSW1)

Used for telegram 111.

Table 1-15 POS_ZSW1 each bit value meaning

Bit Meaning

0~4
The index of the actual effective positioning task (value range: 0~31)
Bit 0~4 are valid only in the position table mode

5~7 Reserved
8 = 1 Negative hardware limit switch signal active
9 = 1 Positive hardware limit switch signal active
10 = 1 Jog mode activated

11~12 Reserved
13 = 1 Position table mode activated
14 Reserved

15
= 1 MDI mode activated
= 0 MDI mode not activated

 Position status word 2 (POS_ZSW2)

Used for telegram 111.

Table 1-16 POS_ZSW2 each bit value meaning

Bit Meaning
0~3 Reserved

4
= 1 Moving forward
= 0 Not moving forward

5
= 1 Moving reversely
= 0 Not moving reversely

6 = 1 Negative software limit switch reached
7 = 1 Positive software limit switch reached

8~15 Reserved

1.3.5 G1_STW、G1_ZSW、MELDW

 Sensor 1 control word (G1_STW)

Used for telegram 3, 5, 102, 105.
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Table 1-17 G1_STW each bit value meaning

Bit Value Meaning

0 1 Function 1 (Bit7=0)：
Request to search sensor index signal position

1~3 — Reserved

4~6 1~3

Command:
0: —
1: Activate function 1a

2: Read sensor index signal position and put it into G1_XIST2
3: Cancel function 1
4~7: —

7 0/1
Mode:
Bit7=0: Sensor index signal position search
Bit7=1: Reserved

8~12 — Reserved

13 1 Request to transmit absolute actual position in G1_XIST2

14 1 Request to switch off the actual value measurements in the drive

15 1 Request to reset a sensor error

a Selection of function 1 (bit 0) and command (bit4~bit7) shall be set simultaneously.

 Sensor 1 status word (G1_ZSW)

Used for telegram 3, 5, 102, 105.

Table 1-18 G1_ZSW each bit value meaning

Bit Value Meaning

0 1
Status:
Function 1 activated

1~3 — Reserved

4 1
Status:
Sensor index signal position available

5~10 — Reserved
11 1 Error acknowledgement in process
12 — Reserved
13 1 Indication of the transmission of absolute actual position in G1_XIST2
14 1 Acknowledgement for indication of invalid G1_XIST1
15 1 Sensor fault present

 telegram status word (MELDW)

Used for telegram 102, 105.

Table 1-19 MELDW each bit value meaning

Bit Meaning
0 Reserved

1
= 1 Torque does not reach the limit value
= 0 Torque has reached the limit value

2~15 Reserved
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Chapter 2 Application description

The PROFINET communication application in Chapters 3 to 6 is based on the following conditions:

1． TIAV17 PLC S7-1500(CPU 1511T-1 PN 6ES7 511-1TK01-0AB0 Firmware V2.8 )

2． Kinco PN servo drive
Drive type Drive firmware PN firmware

FDxx5-PA-004

Software version year is 2024 or later 00000005、10000005FDxx5P-PA-000

MDx0-0xx-DMxK-PA-000

3． GSD file
PN firmware version Applicable GSD file
00000005、10000005 GSDML-V2.43-Kinco-PA5-20240328、GSDML-V2.33-Kinco-PA5-20240328

00000004 GSDML-V2.33-Kinco-MD60-20210507
Note：
a. The default is GSDML-V2.43-Kinco-PA5-20240328
b. If PLC does not support V2.43 GSD，use GSDML-V2.33-Kinco-PA5-20240328

Chapter 7 introduces the method of using S7-200 SMART to control Kinco PN servo drive.

Table 2-1 PROFINET communication parameters

Parameter index Parameter name Description

308001 PN firmware version Applicable PN firmware version for this manual is 00000005, 10000005

308003 PN device name PROFINET device name (read-only)

308004~308007 PN device name 1~4 Used to modify PROFINET device name

308008 IP address Drive IP address (hex, read-only)

308009 Subnet mask Drive subnet mask (hex, read-only)

30800A Default router Drive default router (hex, read-only)

30800B PN enable = 1 PN telegram enabled, using telegram (e. g. telegram 105) control
= 0 PN telegram disabled, using RS232 or acyclic communication control

30800C Enable software limit See Section 5.4.1, Article 5

30800D PN user receive word
See Section 5.4.1, Article 8

30800E PN user send word

30800F~308010 MAC address 1~2 Drive MAC address (hex, read-only)

301101 ECAN synchronization cycle Optional: 1ms, 2ms, 4ms, 8ms
Need to be consistent with the update time of TIA portal configuration

301102 ECAN synchronization mode = 1 Use isochronous synchronization (IRT) mode
= 0 Do not use isochronous synchronization (IRT) mode

301103 ECAN synchronization shift —

600700 Communication abort mode

See Section 1.3.2100C00 Node guard time

100D00 Node guard time factor
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Chapter 3 Acyclic communication

3.1 Drive IP and device name setting

The PROFINET device name of the drive can be set using the KincoServo+ software, TIA portal and

PRONETA software; the IP address of the drive can only be set using TIA portal and PRONETA software. Please

note that if the IP address is to be set using the method described below, the "IP address is set directly at the device"

option should be selected in TIA portal configuration:

To set the device name in the KincoServo+ software, proceed as follows:

1. Disconnect the drive from the PLC and connect the drive to the KincoServo+ software via RS232.

2. Enter the device name in PN_Device_Name1~4 [308004~308007], the length of each PN_Device_Name

is limited to 4 characters:

3. When the setting is completed, you can see that the PN_Device_Name [308003] has been modified:

To set the drive IP and device name in TIA portal, proceed as follows:

1. Connect the drive to the computer with a network cable.

2. Open TIA portal, expand the "Online access" drop-down list, select the corresponding network card, and

click "Update accessible devices". Once the software has scanned the drive, double click "Online &

Diagnostics".
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3. Double-click "Assign IP address" in the "Functions" drop-down list. Fill in the IP address and subnet mask,

and then click the "Assign IP address" button. If you select "Set IP address in the project" in the

configuration, this step can be omitted and you can go directly to step 4 to set the PROFINET device

name.

4. Follow step 3, double click "Assign PROFINET device name" in the "Functions" drop-down list. Fill in

the PROFINET device name and click "Assign name" button, the PROFINET device name must be the

same as the name in the configuration, otherwise the drive can not communicate with the PLC.

5. When the setting is complete, click "Update accessible devices" again to check whether the IP address

and device name have been modified successfully.

Alternatively, the drive IP address and device name can be set using the PRONETA software, which can be

downloaded from the Siemens website: PRONETA - Siemens China.

https://www.siemens.com/cn/zh/products/automation/industrial-communication/profinet/portfolio/proneta.html
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3.2 Project configuration

1. Click menu "Options → Manage general station description files" to install GSD, please take the

GSDML-V2.43-Kinco-PA5-20240328 as the standard. In addition, the GSD to which the PN firmware

00000004 applies is GSDML-V2.33-Kinco-MD60-20210507.

2. In the network view, click "Hardware catalog → Other field devices → PROFINET IO → Drives →

Kinco → PA5" to add a drive and assign it to the PLC:

3. If PLC is required to automatically configure the device name of drive (the premise of automatic

allocation is that the name of the drive is empty), the topology diagram must be connected. In the

topology view, connect the ports according to the actual situation.
Note

 The ports on the topology diagram corresponding to the IN ports on different drives are different.
The IN port of FD5P series drive and MD series drive corresponds to port 1 in the topology
diagram;the IN port of FD5 series drive corresponds to port 2 in the topology diagram.

4. Double-click the PA5 module, click "Ethernet addresses" in "General", and set the configured IP address

and PROFINET device name. The device names need to be consistent with the actual device names of the

drives. When there are multiple drives, the device names cannot be the same:
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5. Click on the "System constants" column and note down the HW_Interface, which will be used later in the

read-write parameters module:

3.3 SINA_PARA_S (FB287) introduction

FB287 can realize acyclic commumication between PLC and drive, and realize servo parameters read-write
function. If you cannot find the corresponding function block (FB), you can download the library file
Drive_Lib_S7_1200_1500_V17 from Siemens official website:

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading

-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
After the download is completed, click menu "Options → Global libraries → Open library", and install the
corresponding library file according to the prompt.

Add FB287 to Main[OB1] and assign variables to its pins as shown below.

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
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FB287 pin definition are as follow：

Table 3-1 FB287 pin definitions

Pin name Data type Description
Start Bool The rising edge triggers data transmission

ReadWrite Bool
= 0 Read
= 1 Write

Parameter Int
Bit8~15: Parameter subindex
Bit0~7: Command word

Index Int Parameter index
ValueWrite1 Real Reserved
ValueWrite2 DInt Data writing area, can write 1 to 4 bytes
AxisNo Byte Fixed to 1

hardwareId HW_IO
See Section 2.3, Article 4, by which the parameter is used to distinguish
between different axes

ValueRead1 Real Reserved
ValueRead2 DInt Data reading area

Error Bool
Indicates read-write parameters error, when the responsing command word in
Kinco communication protocol is 0x80, this bit is set to 1

Note: Command word: read all 40H; Write 1 byte 2FH, write 2 bytes 2BH, and write 4 bytes 23H.

3.4 Read-write parameters using FB287

Take the read-write CMD_q_Max [607300] as an example: the parameter index is 0x6073, the subindex is

0x00, and the data type is uint16, so the command word of writing parameter is 0x2B, and that of reading

parameter is uniformly 0x40.

1. Read CMD_q_Max: When the "Start" pin changes from 0 to 1, the pin "Data Reading Area"

automatically becomes 1968 and “ERROR”pin is 0, the data reading is successful:

2. Write CMD_q_Max: Verify that PN_Enable [30800B] is 0. "ReadWrite" pin is switched to 1,

"Parameter" pin is 0x002B. "Data Writing Area" is written to 1000. Then trigger the "Start" pin to write
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the data. Observing the KincoServo+ software, CMD_q_Max is changed to 1000 DEC.

3.5 Read-write parameters using WRREC and RDREC

The following describes how to read/write parameters using the WRREC / RDREC blocks, which can be

found in "Instructions → Extended instructions → Distributed I/O".

1. First, create a new data block (DB) called Acyclic_Communication. The data in this block is defined as

follows:

The data block Acyclic_Communication is described as follows:
Request Response
ReqID:

0x01: read-only
0x02: readable and writable

Other: Reserved

CMD：
Responsing command word

Subindex / CMD：
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Bit 8~15: parameter subindex
Bit 0~7: sending command word

Value：
Data reading area

Index： Parameter index
Write Value： Data writing area

Other data are in principle consistent with the above figure.

2. Establish the connection of WRREC / RDREC block according to the following figure. The transmission

starts when the "REQ" pin is set to 1. "ID" is the HW_Interface and can be used to distinguish between

different axes. "INDEX" is fixed to 47 and "MLEN" is 0.

3. The following utilizes the WRREC / RDREC block to read/write CMD_q_Max [607300]. The parameter

index is 0x6073, subindex is 0x00, and data type is uint16, so the sending command word for writing

parameter is 0x2B, and for reading parameter is uniformly 0x40.

a. Read CMD_q_Max:

Use KincoServo+ software to check CMD_q_Max is 1000 DEC. The "ReqID" of the Acyclic_Communication

data block is assigned 0x02, "Subindex / CMD" is assigned 0x0040, and "Index" is assigned 0x6073. Trigger

"REQ" pin to complete the data reading, and the reading data is displayed in the "Value" of "Response":
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b. Write CMD_q_Max:

Verify that PN_Enable [30800B] is 0. "ReqID" is assigned 0x02, "Subindex / CMD" is assigned 0x002B,

"Index" is assigned 0x6073, "Write Value" is assigned 1968. Triggers "REQ" pin to complete the data writing. See

the figure below, "CMD" of "Response" is 0x60, indicating that the writing is successful. Use KincoServo+

software to view CMD_q_Max becomes 1968 DEC.

3.6 Fault diagnosis function

Through the online diagnosis interface of TIA portal, the fault information of the drive can be viewed.

Double-click "Online & diagnosis" under PLC_1, click "Diagnosis buffer" in the "Diagnosis" drop-down list, and

the drive fault event can be seen, which is consistent with the error display of KincoServo+ software. The "Details

on event" section below provides the cause of the alarm and what to do about it:
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When the drive fault has been eliminated and confirmed, the diagnostics buffer will show that the drive fault

event has been cleared:
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Chapter 4 Application class 1

4.1 Overview

Kinco PN servo drive can use telegram 1 in Application Class 1. PLC can control the drive through FB285

to achieve speed control. Isochronous synchronization (IRT) operation is not supported.

4.2 Project configuration

1. See Section 3.1 for the modification of the drive IP address and device name.
2. Click menu "Options → Manage general station description files" to install GSD, please take the

GSDML-V2.43-Kinco-PA5-20240328 as the standard. In addition, the GSD to which the PN firmware
00000004 applies is GSDML-V2.33-Kinco-MD60-20210507.

3. In the network view, click "Hardware catalog → Other field devices → PROFINET IO → Drives →
Kinco → PA5" to add a drive and assign it to the PLC:

4. If PLC is required to automatically configure the device name of drive (the premise of automatic
allocation is that the name of the drive is empty), the topology diagram must be connected. In the
topology view, connect the ports according to the actual situation.

Note

 The ports on the topology diagram corresponding to the IN ports on different drives are different.
The IN port of FD5P series drive and MD series drive corresponds to port 1 in the topology
diagram;the IN port of FD5 series drive corresponds to port 2 in the topology diagram.
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5. Double-click the PA5 module, click "Ethernet addresses" in "General", and set the configured IP address

and PROFINET device name. The device names need to be consistent with the actual device names of the

drives. When there are multiple drives, the device names cannot be the same:

6. In the device view, select PLC_1, click "general → PROFINET interface → Advanced options → Real

time settings → IO communication" to set the PLC’s Send clock:

7. In the device view, select PA5, click "Hardware catalog → Module → PROFIdrive Module →

Submodules", delete telegram 3 under "Device overview" first, and then add telegram 1 to the

corresponding position:
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8. Remember the hardware identifier: select telegram 1 → right-click Properties→ System constants →

Hardware identifier:

9. In the device view, select PA5, click "General→ PROFINET interface →Advanced options → Real time

settings → IO cycle" to set the configured drive update time:

10. Add FB285 to Main[OB1] and assign variables to its pins.

If you cannot find the corresponding function block (FB), you can download the library file

Drive_Lib_S7_1200_1500_V17 from Siemens official website:

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-re

ading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW

After the download is completed, click menu "Options → Global libraries → Open library", and install the

corresponding library file according to the prompt.

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
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4.3 SINA_SPEED (FB285) introduction

Table 4-1 describes the FB285 pin definition

Table 4-1 FB285 pin definition

Pin name Data type Description

EnableAxis Bool
Enable axis:
=0 Disable, control word is 0xE
=1 Enable，control word is 0xF

AckError Bool Reset fault, rising edge valid
SpeedSp Real Speed setpoint in RPM
RefSpeed Real Reference speed, must be 1/2 of the maximum speed [607F00] in RPM

ConfigAxis Word

The default is 16#3F, and the corresponding relationship with STW1 is as
follows:

Bit in ConfigAxis Bit in STW1
Bit 0 Bit 1
Bit 1 Bit 2
Bit 2 Bit 3
Bit 3 Bit 4
Bit 4 Bit 5
Bit 5 Bit 6
Bit 6 Bit 11
Bit 7~15: Reserved

See Table 1-6 for the meaning of each bit in STW1
HWIDSTW HW_IO See Section 4.2, Article 7, by which the parameter is used to distinguish

between different axesHWIDZSW HW_IO
AxisEnabled Bool =1 Axis is enabled
Lockout Bool =1 Switching on inhibited

ActVelocity Real Speed actual value in RPM
Error Bool =1 Fault present

Status Int

Status indication:
16#7002: No error
16#8401: Drive fault
16#8402: Switching on inhibited
16#8600: DPRD DAT error
16#8601: DPWR DAT error

DiagId Word Extended communication error
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Chapter 5 Application class 3

5.1 Overview

Kinco PN servo drive can select telegram 9 and 111 in Application Class 3. When using telegram 111, PLC

can control the drive through FB284 to realize the basic positioning (EPOS) function. The operation modes are

Jog, Homing, MDI, position table, etc. Isochronous synchronization (IRT) operation is not supported.

5.2 Project configuration

1. See Section 3.1 for the modification of the drive IP address and device name.

2. Click menu "Options → Manage general station description files" to install GSD, please take the

GSDML-V2.43-Kinco-PA5-20240328 as the standard. In addition, the GSD to which the PN firmware

00000004 applies is GSDML-V2.33-Kinco-MD60-20210507.

3. In the network view, click "Hardware catalog → Other field devices → PROFINET IO → Drives →

Kinco → PA5" to add a drive and assign it to the PLC：

4. If PLC is required to automatically configure the device name of drive (the premise of automatic

allocation is that the name of the drive is empty), the topology diagram must be connected. In the

topology view, connect the ports according to the actual situation.
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Note

 The ports on the topology diagram corresponding to the IN ports on different drives are different.
The IN port of FD5P series drive and MD series drive corresponds to port 1 in the topology
diagram;the IN port of FD5 series drive corresponds to port 2 in the topology diagram.

5. Double-click the PA5 module, click "Ethernet addresses" in "General", and set the configured IP address

and PROFINET device name. The device names need to be consistent with the actual device names of the

drives. When there are multiple drives, the device names cannot be the same:

6. In the device view, select PLC_1, click "general → PROFINET interface → Advanced options → Real

time settings → IO communication" to set the PLC's Send clock:
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7. In the device view, select PA5, click "Hardware catalog → Module → PROFIdrive Module →

Submodules", delete telegram 3 under "Device overview" first, and then add telegram 111 to the

corresponding position:

8. Remember the hardware identifier: select telegram 111 → right-click Properties→ System constants →

Hardware identifier:

9. In the device view, select PA5, click "General→ PROFINET interface → Advanced options → Real time

settings → IO cycle" to set the configured drive update time:
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10. Add FB284 to Main[OB1] and assign variables to its pins.

If you cannot find the corresponding function block (FB), you can download the library file

Drive_Lib_S7_1200_1500_V17 from Siemens official website:

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-re

ading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW

After the download is completed, click menu "Options → Global libraries → Open library", and install the

corresponding library file according to the prompt.

5.3 SINA_POS (FB284) introduction

Table 5-1 describes the FB284 pin definition

Table 5-1 FB284 pin definition

Pin name Data type Description

ModePos Int

Operating mode:
=0 —
=1 Relative positioning
=2 Absolute positioning
=3 —
=4 Active homing
=5 Direct homing
=6 Position table (not supported)
=7 Jog at the specified speed
=8 —

https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
https://support.industry.siemens.com/cs/document/109475044/sinamics-communication-blocks-drivelib-for-reading-and-writing-drive-data-within-tia-portal-context?dti=0&lc=en-WW
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Pin name Data type Description

EnableAxis Bool
=0 Disable, control word is 0xE
=1 Enable，control word is 0xF

CancelTraversing Bool
=1 Do not reject traversing task
=0 Reject traversing task

IntermediateStop Bool
=1 No intermediate stop
=0 Intermediate stop

Positive Bool Positive direction
Negative Bool Negative direction
Jog1 Bool Jog reversely
Jog2 Bool Jog forward
FlyRef Bool Invalid, need to be 0
AckError Bool Reset fault, rising edge valid

ExecuteMode Bool Activate operating mode, rising edge valid

Position DInt
Position set point for operating mode 1, 2
Position table start/New task index for operating mode 6. The value
ranges from 0 to 7

Velocity DInt Speed set point for operating mode 1, 2, 7

ConfigEPos DWord

The default is 16#00000003. The corresponding relationship with
relevant control word is as follows:

Bit in ConfigEPos Bit in control word

Bit 0 STW1 Bit 1

Bit 1 STW1 Bit 2

Bit 2 POS_STW2 Bit 14

Bit 3 POS_STW2 Bit 15

Bit 6 POS_STW2 Bit 2

Bit 8 POS_STW1 Bit 12

Other Bits: Reserved
See Table 1-6 for the meaning of each bit in STW1
See Table 1-13 for the meaning of each bit in the POS_STW1
See Table 1-14 for the meaning of each bit in the POS_STW2

OverV Int
The percentage of the speed set point when the operating mode is 1, 2,
and 7, unit : %, Range 0 to 199%

OverAcc Int
The percentage of the acceleration when the operating mode is 1, 2, and
7, unit : %, Range 0 to 100%

OverDec Int
The percentage of the deceleration when the operating mode is 1, 2, and
7, unit : %, Range 0 to 100%

HWIDSTW HW_IO See Section 5.2, Step 7, for this parameter to distinguish between
different axesHWIDZSW HW_IO

AxisEnabled Bool =1 Axis is enabled
AxisPosOk Bool =1 Target position reached
AxisSpFixed Bool =1 Setpoint position reached
AxisRef Bool =1 Reference point set
AxisWarn Bool =1 Warn present
AxisError Bool =1 Fault present
Lockout Bool =1 Switching on inhibited

ActVelocity DInt Speed actual value

ActPosition DInt Position actual value
ActMode Int Current operating mode
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Pin name Data type Description
EPosZSW1 Word POS_ZSW1 current value, see Table 1-15
EPosZSW2 Word POS_ZSW2 current value, see Table 1-16
ActWarn Word Speed actual value
ActFault Word Drive error code [603F00]
Error Bool =1 Fault present

Status Word

Status indication:
16#7002: No error
16#8401: Drive fault
16#8402: Switching on inhibited
16#8403: Homing procedure forbidden during positioning
16#8600: DPRD DAT error
16#8601: DPWR DAT error
16#8202: Operating mode is selected incorrectly
16#8203: Setpoint is incorrect
16#8204: Position table task index error

DiagID Word Extended communication error

5.4 FB284 function description

5.4.1 Operating condition and setting

1. The initial value of the input pin "ConfigEPos" should be 3.

2. The input pins "CancelTraversing" and "IntermediateStop" are valid for all modes except jog mode, and

should be set to 1 during operation, as follows:

a. When "CancelTraversing" = 0, it means that the current task is canceled, and the deceleration

corresponds to the halt mode [605D00]. The operating mode can be switched after the axis stops.

b. When "IntermediateStop" = 0, it means to pause the current task, and the deceleration corresponds to

the halt mode [605D00]. The axis will continue to run after resetting "IntermediateStop" = 1. The

operating mode can be switched after the axis stops.

3. The input pin "ModePos" is used to select the operating mode; the rising edge of "ExecuteMode" triggers

the positioning movement.

4. Activate software limit switch

After setting the reference point, if you need to use a software limit switch, you need to set bit 2 of

the input pin "ConfigEPos" to 1 ("ConfigEPos" = 16#00000007) or set the En_SoftWare_Limit [30800C]

to 1.
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Activate the software limit function, set the soft positive limit [607D01] and the soft negative limit

[607D02] for the drive.

After you set soft positive limit more than soft negative limit and set the reference point, the

software limit function is enabled.

5. Activate hardware limit switch

If you need to use a hardware limit switch, you need to set bit 3 of the input pin "ConfigEPos" to 1

("ConfigEPos" = 16#0000000B):

Use KincoServo+ software to define the positive limit and negative limit for the DIN of the drive.

The drive can only be operated when the hardware limit switch signal is high.

Please note that only positive and negative limits are configured in the KincoServo+ software, but bit

3 of "ConfigEPos" is not set to 1, then the hardware limit function will not take effect.

6. Activate homing switch

The homing switch signal can be activated by setting bit 6 of the input pin "ConfigEPos" to 1

("ConfigEPos" = 16#0000004B):

The same purpose can be achieved by configuring the home signal for the drive's DIN on the

KincoServo+ software:
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7. Setting and reading servo parameters using telegram 111

The PLC allocates 24-byte receiving and sending areas for telegram 111, which can be viewed in the

FB284 DB block. The "Reserve" variables under the structures "sxSendBuf" and "sxRecvBuf" can be

used to customize the settings and read servo parameters:

The relevant servo parameters are the PN_User_Receive [30800D] and the PN_User_Send [30800E]:

The explanation is as follows:

PN_User_Receive
=0 non-functional
=1 Enable torque limiting and transmit the torque limit value in "Reserve" under "sxSendBuf"

PN_User_Send
=0 non-functional
=2 Transfer the actual current in "Reserve" under "sxRecvBuf"

a. Torque limiting function

When using the torque limiting function, please set the appropriate torque limit value; if the limit

value is too small, it may cause the drive's following error to be too large.

The "Reserve" variable of "sxSendBuf" in the FB284 DB block corresponds to ten times the

Max_Torque%[607200].

First set "Reserve" to 16#1F4 = 500, then the Max_Torque% should be 50%:
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Then set the PN_User_Receive [30800D] to 1: torque as follows:

Max_Torque% has become 50%:

Please note that once [30800D] is set to 1, the torque limit becomes effective, and after setting

[30800D] to 0 again, the torque limit value does not revert to the initial value, but it is possible to set

the torque limit [607200] directly on the KincoServo+ software.

b. Read actual current

First set the PN_User_Send [30800E] to 2: I_q as follows:

In FB284 DB block, "sxRecvBuf" → "Reserve" variable reads drive actual current, unit DEC, which

needs to be converted, such as the reading value converted to Ap: 16 # 15 = 21, 21 / 2048 * 18Ap

(I_Max [651003]) = 0.19Ap:
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5.4.2 Operating mode 1 (Relative positioning)

Requirements:

1. Operating mode "ModePos" = 1

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.

Steps:

1. Specify the target position and target speed through the input pin "Position" and "Velocity". The unit of

position and velocity is DEC. Refer to the drive manual for conversion, and the unit of velocity is

transformed into: DEC = RPM * 512 * feedback_resolution [641003] / 1875.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the target speed and profile

acceleration and deceleration.

3. The direction of movement is determined by the positive or negative value set in "Position".

4. The movement is triggered by the rising edge of "ExecuteMode", and "AxisPosOk" is set to 1 after

reaching the target position. If there is an error locating, "Error" is set to 1.

5. The currently running command can be replaced with a new command via the "ExecuteMode" rising edge.

At any time, it can switch between operating mode 1 and 2. If you need to switch to another operating

mode, the axis must be stationary.

5.4.3 Operating mode 2 (Absolute positioning)

Requirements:

1. Operating mode "ModePos" = 2

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.

Steps:

1. Specify the target position and target speed through the input pin "Position" and "Velocity". The unit of

position and velocity is DEC. Refer to the drive manual for conversion, and the unit of velocity is

transformed into: DEC = RPM * 512 * feedback resolution [641003] / 1875.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the target speed and profile

acceleration and deceleration.

3. When running, the drive will follow the shortest path to the target position, and "Positive" and "Negative"

must be 0.

4. The movement is triggered by the rising edge of "ExecuteMode", and "AxisPosOk" is set to 1 after
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reaching the target position. If there is an error locating, "Error" is set to 1.

5. The currently running command can be replaced with a new command via the "ExecuteMode" rising edge.

At any time, it can switch between operating mode 1 and 2. If you need to switch to another operating

mode, the axis must be stationary.

6. By setting bit 8 of "ConfigEPos" ("ConfigEPos" = 16#00000103), after updating "Position" on the PLC,

there is no need to trigger "ExecuteMode", the new setting value will take effect immediately, and the

servo will immediately execute the absolute positioning instruction according to the target position change.

5.4.4 Operating mode 4 (Active homing)

Requirements:

1. Operating mode "ModePos" = 4

2. "ConfigEPos" = 16#00000003. If hardware limits are used, "ConfigEPos" = 16#0000000B.

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.

Steps:

1. The way and the speed of returning to the reference point should be configured by the KincoServo+

software (PLC only sends the command, and the planning of returning to the homing is set by the servo

parameters). Please refer to the drive manual for the specific way of returning to the homing:

2. A return to the homing motion is triggered by the rising edge of "ExecuteMode". After the motion,

"AxisRef" is set to 1, if there is an error during the operation, "Error" is set to 1.

5.4.5 Operating mode 5 (Direct homing)

Requirements:

1. Operating mode "ModePos" = 5

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. The axis must be stationary.
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Steps:

The homing of the axis is set by the rising edge of the "ExecuteMode". When the homing operation has been

done, the output pin "AxisRef" turns to be 1.

5.4.6 Operating mode 7 (Jog at the specified speed)

Requirements:

1. Operating mode "ModePos" = 7

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. The axis must be stationary.

Steps:

1. Specify the jog speed through the input pin "Velocity", which must be a positive value in unit DEC.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the jog speed and profile acceleration

and deceleration.

3. "CancelTraversing" and "IntermediateStop" have nothing to do with the jog mode. The running direction is

independent of "Positive" and "Negative".

4. There is no need to trigger "ExecuteMode". Reverse jogging when "Jog1" = 1, forward jogging when

"Jog2" = 1. "Jog1" and "Jog2" can only be triggered separately. When "Jog1" and "Jog2" are 0 or 1 at the

same time, the axis stops.
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Chapter 6 Application class 4

6.1 Overview

Kinco PN servo drive can select telegram 3, 5, 102, 105 in Application Class 4. The technology object is

configured in PLC and controlled using PLC_open function blocks such as MC_Power and MC_MoveAbsolute,

where the position loop calculation of the servo three-loop control is completed in PLC, and the drive is in speed

mode. The functional differences between the different telegrams are shown in Table 6-1.

Table 6-1 Application Class 4 telegram function difference

Telegram IRT supported Torque limiting supported DSC supported

105 Yes Yes Yes

102 Yes Yes No

5 Yes No Yes

3 Yes No No

6.2 Project configuration

1. See Section 3.1 for the modification of the drive IP address and device name.

2. Click menu "Options → Manage general station description files" to install GSD, please take the

GSDML-V2.43-Kinco-PA5-20240328 as the standard. In addition, the GSD to which the PN firmware

00000004 applies is GSDML-V2.33-Kinco-MD60-20210507.

3. In the network view, click "Hardware catalog → Other field devices → PROFINET IO → Drives →

Kinco → PA5" to add a drive and assign it to the PLC：
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4. The topology diagram must be connected to use the isochronous synchronization mode. In the topology

view, connect the ports according to the actual situation.

5. In the device view, select PLC_1, click "General → PROFINET interface → Advanced options → Real

time settings" to set the send clock and enable the synchronization mode:

6. In the device view, select PA5, click "Hardware catalog → Module → PROFIdrive Module →

Submodules", delete telegram 3 under "Device overview" first, and then add telegram 105 to the

corresponding position:

Note

 The ports on the topology diagram corresponding to the IN ports on different drives are different.
The IN port of FD5P series drive and MD series drive corresponds to port 1 in the topology
diagram;the IN port of FD5 series drive corresponds to port 2 in the topology diagram.
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7. Click "General → PROFINET interface → Advanced options → Isochronous mode", then check telegram

105 below to enable the synchronization mode, and set Ti to 0.375ms:

8. In IRT mode, device update time = PLC send clock:

The update time of the configuration needs to be consistent with the ECAN_Sync_Cycle [301101], set to

0 for 1ms:

9. Enable isochronous synchronization mode on the drive side by setting ECAN_Sync_Clock [301102] to 1

and also setting ECAN_Sync_Shift [301103] to 4:

10. After the device is configured, click "Technology objects" in the drop-down list of PLC_1 on the left side

to add a new technology object and select the positioning axis:
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11. Click "Technology objects → PositioningAxis_1 → Configuration → Basic parameters", select Axis type:

12. Click "Hardware interface → Drive", select telegram 105：

13. Kinco PN servo drives support incremental and absolute encoders. Click "Hardware interface → Encoder",

select "Incremental" if a Kinco single-turn encoder motor is used:
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Select "Cyclic absolute" if a Kinco multi-turn absolute encoder motor is used:

14. Click on "Data exchange with the drive" to set the Reference speed, Maximum speed and Reference

torque:

The Reference speed is 1/2 of the Max_Speed [607F00]:

CMD_q_Max [607300] and Max_Torque% [607200] of the drive are related, and the Reference torque

can be taken as the initial default value of CMD_q_Max [607300], with the unit of Ap, which is generally

the lesser of the two values of the drive peak current and the motor peak current:

15. Click on "Data exchange with encoder". If a Kinco single-turn encoder motor is used, the Increments per

revolution is Feedback _Resolution [641003]. For Fine resolution, select Gx_XIST1 bit 0:
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If a Kinco multi-turn absolute encoder motor is used, the Increments per revolution is Feedback _Resolution

[641003], e.g. 65536, and the Number of revolutions is also set to 65536, with Fine resolution selections

G1_XIST1 bit 0 and G1_XIST2 bit 0:

16. Click "Extended parameters → Mechanics" to set the position parameters：

17. Click "Extended parameters → Position monitoring → Following error" to disable the following error

monitoring. When monitoring is enabled and the following error setting is small, the PLC will report error

easily after enabling operation:
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18. Click "Extended parameters → Limits → Torque limits" and select "On motor side":

19. DSC can be enabled by clicking "Extended parameters → Control loop", see section 6.5 for details on

how to use it.

20. After the technology object has been configured, click "Program blocks → MC-Servo [OB91]" in the

drop-down list of PLC_1 on the left side, and then right-click to open the properties to set the PLC

application cycle. Please note that when using the DSC function, the PLC application cycle, device update

cycle (see Artile 8) and ECAN_Sync_Cycle [301101] must be the same.

21. Configuration completed, program written, compiled and downloaded to PLC:
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6.3 MC_Home introduction

The drive must complete homing motion before absolute positioning. The homing trajectory is generated by

the PLC, and the homing switch and limit switches are usually connected to the PLC:
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Table 6-2 describes the MC_Home pin definition

Table 6-2 MC_Home pin definition

Pin name Data type Description

Axis
TO_PositioningAxis
TO_SynchronousAxis
TO_ExternalEncoder

Technology objects

Execute Bool Start job with a rising edge

Position LReal The specified value is used according to the selected "Mode"

Mode Int

Homing modes:
= 0 Direct homing (absolute), the current position of the technology object
is set to the value of parameter "Position".
= 1 Direct homing (relative), the current position of the technology object
is shifted by the value of parameter "Position
= 2 Passive homing, the current position of the technology object is set to
the value of parameter "Position".
= 3 Active homing, the current position of the technology object is set to
the value of parameter "Position".
= 6 Absolute encoder adjustment (relative), the current position is shifted
by the value of parameter "Position".
= 7 Absolute encoder adjustment (absolute), the current position is set to
the value of parameter "Position".
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Pin name Data type Description

ReferenceMarkPosition LReal
Display of the position at which the technology object was homed
(valid when "Done" = TRUE)

Done Bool = 1 Job is completed
Busy Bool = 1 The job is being processed

CommandAborted Bool =1 The job was aborted by another job during execution
Error Bool =1 Error, see "ErrorID"
ErrorID Word Please consult the information system of TIA portal for help

The homing modes supported by different encoders are shown in Table 6-3.

Table 6-3 Supported homing mode

Homing mode
Incremental encoder

(Kinco single-turn encoder)
Absolute encoder

(Kinco multi-turn absolute encoder)
Active homing
("Mode"= 3 )

√ —

Passive homing
("Mode"= 2 )

√ —

Set actual position
("Mode"= 0 )

√ √

Relative offset to the actual position
("Mode"= 1)

√ √

Absolute encoder adjustment
("Mode"= 6、7 )

— √

6.3.1 Homing mode 0 (Absolute direct homing)

The axis does not move after the MC_Home is executed. The result of executing the instruction is that the

actual position of the axis is directly changed to "Position specified in MC_Home". In the following example,

"Position" = 0 mm, then the actual position of the axis becomes 0 mm after homing.The coordinate value belongs

to the "absolute" coordinate value, that is, the axis has established an absolute coordinate system and can be

absolutely positioned.
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The above figure shows the state before homing, the current position of the axis is 45 mm and the drive actual

position [606300] is 49152 DEC. In Section 6.2, Article 16, the leadscrew pitch is 60 mm/rot, the conversion

relation is as follows:

Actual position of PLC technology object axis (mm) = (Current servo actual position [606300] - Servo actual

position [606300] at PLC power-up) / Feedback _Resolution [641003] * Leadscrew pitch

Or

Actual position change of PLC technology object axis (mm) = Servo actual position [606300] change /

Feedback _Resolution [641003] * Leadscrew pitch

The following figure shows the state after homing, the actual position of the axis = "Position specified in

MC_Home" = 0 mm, and the drive actual position [606300] does not change and remains at 49152 DEC.

After the homing motion is completed, no matter what position the axis moves to, as long as the PLC is

powered off, the actual position data of the axis will be lost and become 0, instead of being converted over with the

current encoder value of the drive.

6.3.2 Homing mode 1 (Relative direct homing)

The axis does not move after the MC_Home is executed. The result of executing the instruction is that the

actual position of the axis is directly changed to "current position + Position specified in MC_Home". In the

following example, "Position" = 10 mm, the current position of the axis was 20 mm before MC_Home was

executed, and the actual position of the axis after MC_Home was executed became 30 mm.
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The above figure shows the state before homing, the current position of the axis is 20 mm and the drive actual

position [606300] is 71104 DEC.

The following figure shows the state after homing, the actual position of the axis = "current position + Position

specified in MC_Home" = 30 mm, and the drive actual position [606300] does not change and remains at 71104

DEC.

After the homing motion is completed, no matter what position the axis moves to, as long as the PLC is

powered off, the actual position data of the axis will be lost and become 0, instead of being converted over with the

current encoder value of the drive.



Kinco PN servo driver PROFINET communication manual Chapter 6 Application class 4

47

6.3.3 Homing mode 2 (Passive homing)

When only MC_Home is triggered, the axis will not move, and other motion control instructions (e.g.

MC_MoveRelative) are needed to make the axis run, and when the axis reaches the homing switch, the current

position will be changed to "Position specified in MC_Home".

Passive homing requires the MC_Home command to be used in combination with the MC_MoveAbsolute or

MC_MoveRelative or MC_MoveVelocity command, and the axis is completed to the homing in the process of

executing other motion commands. After PLC power off and restart, the actual position data of the axis will be lost.

1. Use zero mark via PROFIdrive telegram (i.e. detecting zero mark)

Motion sequence:

a. Start passive homing via the "MC_Home" instruction.

b. Move via other motion control instruction (e.g. MC_MoveRelative). The detection of the homing

mark is enabled when the actual position value of the axis moves in the assigned homing direction.

c. When zero mark is detected, the actual position is changed to "Position specified in MC_Home".

Or

a. Move in the assigned homing direction via other motion control instruction (e.g.

MC_MoveRelative).

b. Start passive homing via the "MC_Home" instruction.

c. When zero mark is detected, the actual position is changed to "Position specified in MC_Home".

2. Use reference cam and zero mark via PROFIdrive telegram (i.e. detecting zero mark after digital input is

detected.)

Motion sequence:

a. Start passive homing via the "MC_Home" instruction.

b. Move via other motion control instruction (e.g. MC_MoveRelative) and wait for the digital input.

c. Detection of zero mark will begin as soon as the digital input is detected and disengaged.

d. When zero mark is detected, the actual position is changed to "Position specified in MC_Home".

Or

a. Move via other motion control instruction (e.g. MC_MoveRelative).

b. Start passive homing via the "MC_Home" instruction and wait for the digital input.

c. Detection of zero mark will begin as soon as the digital input is detected and disengaged.

d. When zero mark is detected, the actual position is changed to "Position specified in MC_Home".
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3. Use homing mark via digital input (i.e. detecting digital input)

Motion sequence:

a. Start passive homing via the "MC_Home" instruction.

b. Move via other motion control instruction (e.g. MC_MoveRelative) and wait for the digital input.

c. When the digital input is detected, the actual position is changed to the "Position specified in

MC_Home".

Or

a. Move via other motion control instruction (e.g. MC_MoveRelative).

b. Start passive homing via the "MC_Home" instruction and wait for the digital input.

c. When the digital input is detected, the actual position is changed to the "Position specified in

MC_Home".

6.3.4 Homing mode 3 (Active homing)

The technology object performs a homing movement according to the configuration:

1. Use zero mark via PROFIdrive telegram (i.e. detecting zero mark)

Motion sequence:

a. Start active homing via the "MC_Home" instruction.

b. Look for the zero mark during motion.

c. When zero mark is detected, the actual position is changed to "Position specified in MC_Home" -

"Home position offset":

d. The axis will then move a distance of the "Home position offset" and the actual position will be equal

to "Position specified in MC_Home" after completion.
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2. Use reference cam and zero mark via PROFIdrive telegram (i.e. detecting zero mark after digital input is

detected.)

Motion sequence:

a. Start active homing via the "MC_Home" instruction.

b. The axis detects digital input during motion.

c. Decelerates when digital input is detected, and detect zero mark when the falling edge of digital input

is detected.

d. When zero mark is detected, the actual position is changed to "Position specified in MC_Home" -

"Home position offset".

e. The axis will then move a distance of the "Home position offset" and the actual position will be equal

to "Position specified in MC_Home" after completion.

3. Use homing mark via digital input (i.e. detecting digital input)

Motion sequence:

a. Start active homing via the "MC_Home" instruction.

b. Detection of the rising edge at the digital input, while moving with homing velocity.

c. Decelerates when the rising edge of digital input is detected; when the falling edge of digital input is

detected, the actual position is changed to "Position specified in MC_Home" - "Home position

offset".

d. The axis will then move a distance of the "Home position offset" and the actual position will be equal

to "Position specified in MC_Home" after completion.

6.3.5 Homing mode 6 (Absolute encoder adjustment (relative))

This mode is only for the connected encoder type is absolute value encoder, in this mode, after the MC_Home

instruction is triggered, the axis will not run, and will not search for the home switch, it will set the current position

value to "current position + Position specified in MC_Home". The absolute value is stored retentively in the CPU,

and will not be lost after the CPU power off.

6.3.6 Homing mode 7 (Absolute encoder adjustment (absolute))

This mode is only for the connected encoder type is absolute value encoder, in this mode, after the MC_Home

instruction is triggered, the axis will not run, and will not search for the home switch, it will set the current position

value to "Position specified in MC_Home". The absolute value is stored retentively in the CPU, and will not be lost

after the CPU power off.



Kinco PN servo driver PROFINET communication manual Chapter 6 Application class 4

50

6.4 MC_TorqueLimiting introduction

The CMD_q_Max [607300] and the Max_Torque% [607200] of the drive are associated. The maximum

current (torque) can be limited using the MC_TorqueLimiting instruction.

1. The MC_TorqueLimiting pin is defined in Table 6-4.

Table 6-4 MC_TorqueLimiting pin definition

Pin name Data type Description

Axis
TO_SpeedAxis

TO_PositioningAxis
TO_SynchronousAxis

Technology objects

Enable Bool = 1 Activate torque limiting function

Limit LReal
Equal to CMD_q_Max [607300] value in Ap
Range: 0 to drive / motor peak current

Mode DInt
= 0 Torque limit mode
= 1 —

InClamping Bool —
InLimitation Bool = 1 I_q [607800] reaches CMD_q_Max [607300]

Busy Bool = 1 Tasks in progress
Error Bool = 1 Error, see "ErrorID"
ErrorID Word Please consult the information system of TIA portal for help

2. Enable the torque limit function, "Enable" pin set to 1, in the "Limit" pin input target maximum current value

10 (unit Ap), then drive CMD_q_Max [607300] becomes 10 Ap:

3. When I_q [607800] reaches CMD_q_Max [607300], the output pin "InLimitation" is set to 1, and the drive message

status word MELDW’s bit 1 is set to 0 (see Table 1-19).

6.5 DSC (Dynamic Servo Control) introduction

When using telegram 3 and 102, the drive works in speed mode, the position loop calculation is completed

by the PLC, and the calculation update cycle of the position loop is the same as the communication cycle of
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PROFINET. Telegram 5 and 105 support Dynamic Servo Control (DSC). When DSC is enabled, the drive works

in interpolation mode, and the calculation and update cycle of the position loop is the local control cycle of the

drive. The DSC function puts the PLC position loop calculation into the drive to complete, and the PLC only

needs to perform the central interpolation calculation of the position, and then adjust the position loop calculation

of the drive periodically through the PROFINET interface.

In the technology objects configuration interface, click "Extended parameters → Control loop" to set the

parameters related to the DSC function, as shown in the following figure:

In the above figure, "Gain (Kv factor)" can not be 0, its specific value will not affect the servo's position loop

proportional gain, keep it as the default value; "Pre-control" is the percentage of speed feedforward, and the role

of K_Velocity_FF [60FB02] is the same:

Please note that when using the DSC function, if the type of encoder connected is a single-turn encoder

(incremental encoder), it is necessary to set the Store_Position [60FB06] to 1, then write 0 to the Position_Shift

[60FB07] and store the control parameters:
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Chapter 7 S7-200 SMART Application

7.1 Application description

The PROFINET communication application in this chapter is based on the following conditions:

1． STEP 7-Micro/Win SMART V02.08.02.00_00.01

PLC S7-200 SMART(CPU ST20 DC/DC/DC V02.04.01_00.00.03.00 固件 V2.6)

2． Kinco PN servo drive
Drive type Drive firmware PN firmware

FDxx5-PA-004
Software version vintage 2024 and beyond 00000005, 10000005FDxx5P-PA-000

MDx0-0xx-DMxK-PA-000

3． GSD file
PN firmware version Applicable GSD file
00000005、10000005 GSDML-V2.33-Kinco-PA5-20240328

00000004 GSDML-V2.33-Kinco-MD60-20210507

Table 2-1 describes the parameters related to the servo PROFINET communication.

7.2 Acyclic communication

7.2.1 Project configuration

1. Click the menu "File → GSDML Management" to install the GSD file

(GSDML-V2.33-Kinco-PA5-20240328). After successful installation, there is no need to repeat the

installation for a new project:
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2. Click "Tools → Find PROFINET Devices" to ensure that the servo is connected. See Section 3.1 to

modify the servo IP address and device name, or click "Edit" here to modify the device name:

3. Click "Tools → PROFINET", select "Controller", set the PLC IP address and station name, and click

"Next" :

4. Add the servo to the device table, set the IP address and device name (need to be the same as the actual

connected device), and then click "Next" :
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5. Add the PROFIdrive module for the servo, and the submodule of Standard Telegram 3 will be added by

default. If only acyclic communication is carried out, the submodule of the telegram can be deleted:

6. Then keep clicking "Next" until it is successfully generated:

7. In the main program, call SINA_PARA_S and write the following program:
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8. The symbol table address used in the program is defined as shown in the following figure:

9. Before downloading the program, assign the V-address area used by the library:
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7.2.2 SINA_PARA_S introduction

Table 7-1 describes the SINA_PARA_S pin definition.

Table 7-1 SINA_PARA_S pin definitions

Pin name Data type Description
Start Bool The rising edge triggers data transmission

ReadWrite Bool 0=Read; 1=Write
Parameter Int Bit8~15: Parameter subindex; Bit0~7: Command word
Index Int Parameter index

ValueWrite1 Real Reserved
ValueWrite2 DInt Data writing area, can write 1 to 4 bytes
DeviceNo Word Device number

Device_Parameter DWord

PROFINET device parameters, byte offset as follows:
0: Axis number
1: Reserved
2~5: API number(Fixed to 14848)
6~7: Slot number
8~9: Subslot number

ValueRead1 Real Reserved
ValueRead2 DInt Data reading area

Format Byte

Parameter format:
02H: Int8
03H: Int16
04H: Int32
05H: Unsigned8
06H: Unsigned16
07H: Unsigned 32
08H: Float
10H: Octal string (16bit)
13H: Time diff (32bit)
41H: Byte
42H: Word
43H: Double word
44H: Error

ErrorNo Word Error number according to the PROFIdrive specification

ErrorID DWord
First word: Binary encoding indicating a faulty parameter access
Second word: Type of fault

PN_Error_Code DInt Error code according to the PROFINET protocol

Status Byte
Bit0~4: System definition error codes for instructions RDREC and WRREC;
Bit5: Error; Bit6: Request in progress

Status_bit Byte
Indicates the status of the reading/writing parameter, which is 4 when the
reading/writing is successful

Note: Command word—Read: 40H; Write 1 byte: 2FH; Write 2 bytes: 2BH; Write 4 bytes: 23H.

The Device_Parameter in Table 7-1 can be confirmed in the following figure:
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7.2.3 Read-write parameters using SINA_PARA_S

1. Read feedback_resolution: the parameter index is 0x6410, the parameter subindex is 0x03, and the read

parameter command word is unified as 0x40. When the "Start" pin changes from 0 to 1, the

"ValueRead2" pin in the data reading area automatically becomes 10000, and the "Status_bit" pin is 4,

the data reading is successful.

2. Write target_position: the parameter index is 0x607A, the parameter subindex is 0x00, and the data type

is Int32, so the write parameter command word is 0x23, the "ReadWrite" pin is switched to 1. The data
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writing area is written to -10000. When the "Start" pin is changed from 0 to 1, the data is written. The

"Status_bit" pin is 4, and the data is written successfully. Observing the KincoServo+ software, the

target position is changed to -10000.

7.3 Telegram 1 application

7.3.1 Project configuration

1. Click the menu "File → GSDML Management" to install the GSD file

(GSDML-V2.33-Kinco-PA5-20240328). After successful installation, there is no need to repeat the

installation for a new project:
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2. Click "Tools → Find PROFINET Devices" to ensure that the servo is connected. See Section 3.1 to

modify the servo IP address and device name, or click "Edit" here to modify the device name:

3. Click "Tools → PROFINET", select "Controller", set the PLC IP address and station name, and click

"Next" :

4. Add the servo to the device table, set the IP address and device name (need to be the same as the actual

connected device), and then click "Next" :
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5. Add the PROFIdrive module to the servo, then select and delete the submodule of standard telegram 3

added by default, add the submodule of standard telegram 1, and note down the start address of the I/O

data which is needed when calling SINA_SPEED:

6. Then keep clicking "Next" until it is successfully generated:

7. In the main program, call SINA_SPEED and write the following program, where the inputs

"Starting_I_add" and "Starting_Q_add" must correspond to the start address of the I/O data of telegram 1

(see step 5) :
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8. Before downloading the program, assign the V-address area used by the library:

7.3.2 SINA_SPEED introduction

Table 7-2 describes the SINA_SPEED pin definition.

Table 7-2 SINA_SPEED pin definition

Pin name Data type Description
EnableAxis Bool =1 Enable
AckError Bool Reset fault, rising edge valid
SpeedSp Real Speed setpoint in RPM
RefSpeed Real Reference speed, must be 1/2 of the maximum speed [607F00] in RPM

ConfigAxis Word

The default is 16#3F, and the corresponding relationship with STW1 is as
follows:

Bit in ConfigAxis Bit in STW1
Bit 0 Bit 1
Bit 1 Bit 2
Bit 2 Bit 3
Bit 3 Bit 4
Bit 4 Bit 5
Bit 5 Bit 6
Bit 6 Bit 11

See Table 1-6 for the meaning of each bit in STW1
Starting_I_add DWord Start address of the PN I area of telegram 1
Starting_Q_add DWord Start address of the PN Q area of telegram 1
AxisEnabled Bool =1 Axis is enabled

Lockout Bool =1 Switching on inhibited
ActVelocity Real Speed actual value in RPM

Error Bool =1 Fault present
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7.4 Telegram 111 application

7.4.1 Project configuration

1. Click the menu "File → GSDML Management" to install the GSD file

(GSDML-V2.33-Kinco-PA5-20240328). After successful installation, there is no need to repeat the

installation for a new project:

2. Click "Tools → Find PROFINET Devices" to ensure that the servo is connected. See Section 3.1 to

modify the servo IP address and device name, or click "Edit" here to modify the device name:

3. Click "Tools → PROFINET", select "Controller", set the PLC IP address and station name, and click

"Next" :
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4. Add the servo to the device table, set the IP address and device name (need to be the same as the actual

connected device), and then click "Next" :

5. Add the PROFIdrive module to the servo, then select and delete the submodule of standard telegram 3

added by default, add the submodule of standard telegram 111, and note down the start address of the I/O

data which is needed when calling SINA_POS:

6. Then keep clicking "Next" until it is successfully generated:
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7. In the main program, call SINA_ POS and write the following program, where the inputs " St_I_add " and

"St_Q_add" must correspond to the start address of the I/O data of telegram 111 (see step 5) :

8. The symbol table address used in the program is defined as shown in the following table:

Mode_setting VW7000
Position_setting VD7002
Velocity_setting VD7006

Enable V7010.0
Non_stop V7010.1
Non_pause V7010.2

Start V7010.3
Control_table VD8000
Status_table VD7500
ActPosition VD7020
ActVelocity VD7024
Warn_Code VW7028
Fault_Code VW7030

Done V7032.0
OverV VW8002
OverAcc VW8004
OverDec VW8006

ConfigEpos VD8008

9. Before downloading the program, assign the V-address area used by the library:
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10. After downloading the program, you can test it with a status chart:

7.4.2 SINA_POS introduction

Table 7-3 describes the SINA_POS pin definition

Table 7-3 SINA_POS pin definition

Pin name Data type Description

ModePos Int

Operating mode:
=0 —
=1 Relative positioning
=2 Absolute positioning
=3 —
=4 Active homing
=5 Direct homing
=6 Position table (not supported)
=7 Jog at the specified speed
=8 —

Position DInt Position setpoint for operating mode 1, 2
Velocity DInt Speed setpoint for operating mode 1, 2, 7

EnableAxis Bool
=0 Disable, servo control word is 0xE
=1 Enable, servo control word is 0xF

CancelTraversing Bool
=1 Do not reject traversing task
=0 Reject traversing task

IntermediateStop Bool
=1 No intermediate stop
=0 Intermediate stop

Execute Bool Activate operating mode, rising edge valid

St_I_add DWord Start address of the PN I area of telegram 111

St_Q_add DWord Start address of the PN Q area of telegram 111
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Pin name Data type Description

Control_table DWord

A pointer to the start address of Control_table, for example &VD8000

Byte Bit7 Bit 6 Bit 5 Bit 4
Bit
3

Bit
2

Bit 1 Bit0

0 Reserved Reserved
Ack-
Error

Reserved
Jog
2

Jog
1

Negative Positive

1 Reserved

2 OverV: Percentage of Speed Setpoint at Operating Modes 1, 2, 7, unit %, range 0 to
199%3

4 OverAcc: Acceleration percentage when operating mode is 1, 2 and 7, unit %, range
0~100%5

6 OverDec: Deceleration percentage when operating mode is 1, 2 and 7, unit %, range
0~100%7

8 ConfigEpos ——
Bit0: Coast stop Bit1: Quick stop
Bit2: Activate software limit Bit3: Activate hardware limit
Bit6: Reference point switch
Bit8: The absolute positioning set point is changed immediately
Note that the initial value of the ConfigEpos is 3.

9

10

11

Status_table DWord

A pointer to the start address of Status_table, for example &VD7500
Byte Bit7 Bit6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0

0 Reserved
Over-
range

Axis-
Error

Axis-
Warn

Lock-
out

Axis-
Ref

Axis-
PosOk

Axis-
Enabled

1

Error ID——
0: No error
1: Drive fault
2: Drive disabled
3: Unsupported mode
4: OverV, OverAcc and OverDec is overranged

2
ActMode: Current operating mode

3

4
POS_ZSW1 current value, see Table 1-15

5

6
POS_ZSW2 current value, see Table 1-16

7

ActVelocity DWord Speed actual value
ActPosition DWord Position actual value
Warn_code Word Servo warn code
Fault_code Word Servo error code [603F00] absolute positioning.

Done Bool
The target position is reached when operation mode is relative or absolute
positioning.

7.4.3 Operating condition and setting

1. Enabled by entering pin "EnableAxis" = 1, "AxisEnabled" in "Status_table" is 1 if the servo is ready and

fault-free ("AxisError " = 0).

2. The input pin "CancelTraversing" and "IntermediateStop" are valid for all modes except jog mode, and

should be set to 1 during operation, as follows:

a. When "CancelTraversing" = 0, it means that the current task is canceled, and the deceleration corresponds

to the halt_mode [605D00]. The operating mode can be switched after the axis stops.
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b. When "IntermediateStop" = 0, it means to pause the current task, and the deceleration corresponds to the

halt_mode [605D00]. The axis will continue to run after resetting "IntermediateStop" = 1. The operating

mode can be switched after the axis stops.

3. The input pin "ModePos" is used to select the operating mode; the rising edge of "Execute" triggers the

positioning movement.

4. Activate software limit switch

After setting the reference point, if you need to use a software limit switch, you need to set bit 2 of

the input pin "ConfigEPos" to 1 ("ConfigEPos" = 16#00000007) or set the En_SoftWare_Limit [30800C]

to 1.

Activate the software limit function, set the soft positive limit [607D01] and the soft negative limit

[607D02] for the servo.

After you set soft positive limit more than soft negative limit and set the reference point, the

software limit function is enabled.

5. Activate hardware limit switch

If you need to use a hardware limit switch, you need to set bit 3 of the input pin "ConfigEPos" to 1

("ConfigEPos" = 16#0000000B):

Use KincoServo+ software to define the positive limit and negative limit for the DIN of the servo.

The servo can only be operated when the hardware limit switch signal is high.

Please note that only positive and negative limits are configured in the KincoServo+ software, but bit

3 of "ConfigEPos" is not set to 1, then the hardware limit function will not take effect.

7.4.4 Operating mode 1 (Relative positioning)

Requirements:

1. Operating mode "ModePos" = 1

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.
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Steps:

1. Specify the target position and target speed through the input pin "Position" and "Velocity". The unit of

position and velocity is DEC. Refer to the servo drive manual for conversion, and the unit of velocity is

transformed into: DEC = RPM * 512 * feedback_resolution [641003] / 1875.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the target speed and profile

acceleration and deceleration.

3. The direction of movement is determined by the positive or negative value set in "Position".

4. The movement is triggered by the rising edge of "Execute", and "AxisPosOk" is set to 1 after reaching the

target position. If there is an error locating, "AxisError" is set to 1.

5. The currently running command can be replaced with a new command via the "Execute" rising edge. At

any time, it can switch between operating mode 1 and 2. If you need to switch to another operating mode,

the axis must be stationary.

6. Please note that "Execute" needs to be reset to 0 after the relative positioning motion is triggered by the

rising edge of "Execute".

7.4.5 Operating mode 2 (Absolute positioning)

Requirements:

1. Operating mode "ModePos" = 2

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.

Steps:

1. Specify the target position and target speed through the input pin "Position" and "Velocity". The unit of

position and velocity is DEC. Refer to the servo drive manual for conversion, and the unit of velocity is

transformed into: DEC = RPM * 512 * feedback_resolution [641003] / 1875.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the target speed and profile

acceleration and deceleration.

3. The servo will follow the shortest path to the target position when running. "Positive" and "Negative" must

be 0.

4. The movement is triggered by the rising edge of "Execute", and "AxisPosOk" is set to 1 after reaching the

target position. If there is an error locating, "AxisError" is set to 1.

5. The currently running command can be replaced with a new command via the "Execute" rising edge. At

any time, it can switch between operating mode 1 and 2. If you need to switch to another operating mode,

the servo must be stationary.
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6. By setting bit 8 of "ConfigEPos" ("ConfigEPos" = 16#00000103), after updating "Position" on the PLC,

there is no need to trigger "Execute", the new setting value will take effect immediately, and the servo will

immediately execute the absolute positioning instruction according to the target position change.

7. Please note that "Execute" needs to be reset to 0 after the absolute positioning motion is triggered by the

rising edge of "Execute".

7.4.6 Operating mode 4 (Active homing)

Requirements:

1. Operating mode "ModePos" = 4

2. "ConfigEPos" = 16#00000003. If hardware limits are used, "ConfigEPos" = 16#0000000B.

3. "EnableAxis" = 1

4. "CancelTraversing" and "IntermediateStop" must be 1, and "Jog1" and "Jog2" must be 0.

5. One of "Negative" and "Positive" must be set to 1.

Steps:

1. The way and the speed of returning to the reference point should be configured by KincoServo+ software

(PLC only sends the command, and the planning of returning to the reference point is set by the servo

parameters). Please refer to the servo drive manual for the specific way of returning to the reference point:

2. A return to the reference point motion is triggered by the rising edge of "Execute", which should remain 1

during the motion. After the motion, "AxisRef" is set to 1, and if there is an error during the operation,

"AxisError" is set to 1.

7.4.7 Operating mode 5 (Direct homing)

Requirements:

1. Operating mode "ModePos" = 5

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. The axis must be stationary.
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Steps:

The reference point of the axis is set by the rising edge of the "Execute". When the homing operation has been done,

the output pin "AxisRef" turns to be 1.

7.4.8 Operating mode 7 (Jog at the specified speed)

Requirements:

1. Operating mode "ModePos" = 7

2. "ConfigEPos" = 16#00000003

3. "EnableAxis" = 1

4. The axis must be stationary.

Steps:

1. Specify the jog speed through the input pin "Velocity", which must be a positive value in unit DEC.

2. Use "OverV", "OverAcc" and "OverDec" to scale the percentage of the jog speed and profile acceleration

and deceleration.

3. "CancelTraversing" and "IntermediateStop" are not related to the jog mode. The running direction is

independent of "Positive" and "Negative".

4. There is no need to trigger "Execute". Reverse jogging when "Jog1" = 1, forward jogging when "Jog2" = 1.

"Jog1" and "Jog2" can only be triggered separately. When "Jog1" and "Jog2" are 0 or 1 at the same time,

the axis stops.
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